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ABSTRACT
GaMField is an integrated system tool, released in 2011 and available
for free, able to construct and visualize subsurface sources in 3-D space
and to compute their gravimetric and magnetic effects. Since its first release, we have received feedback and new features implementation requests from scientists worldwide. According to such requests,
significant advances have been introduced into the software to broaden
its field of application in potential field analysis and interpretation as
described in this paper.

1. Introduction
GaMField was released in 2011 [Pignatelli et al.
2011] to realize the graphical windows-interactive constructions of complex 3-D synthetic gravimetric and
magnetic sources. Such synthetic models are widely
used by researchers to verify potential data fields interpretation algorithms and to predict magnetic or gravity
response of a given geological model. [Last and Kubic
1983, Guillen and Menichetti 1984, Li and Oldenburg
1996, Fedi and Rapolla 1999, Pignatelli et al. 2007, Nicolosi et al. 2006].
The software can be freely downloaded, after the
registration, at the following URL:
http://geosoftware.sci.ingv.it
where a forum has been set-up for GaMField users and
for other possible future geophysical software applications. GaMField has been downloaded by hundreds of
users and it has got citations since its presentation [Tontini 2012, Speranza et al. 2012, Al-Rahim 2013, Jeshvaghani and Darijani 2014, Speranza and Minelli 2014,
Guo et al. 2015, Liu et al. 2015, Montesinos et al. 2016,
Pan et al. 2016, Kim and Wessel 2016]. Many researchers have joined the web forum and provided with
a large number of comments and suggestions for im-

provements. We have collected these useful inputs and
decided to broaden GaMField field of applications with
the aim to make it available to the scientific community operating in the area of potential field analysis and
interpretation.
Basically three main newly developed tools are
now implemented:
- use of space vertical cross sections to build up
sources;
- a new interactive GUI to simulate topographic effects;
- STL 3D objects files import and export.
Minor additional improvements have been also introduced. GaMField is maintained by INGV (Italian National Institute of Geophysics and Volcanology).
2. New tools description
An extensive description of GaMField main principles and its modules can be found in Pignatelli et al.
[2011] as well as in GaMField help. In Figure 1 a
schematic representation of such modules and their
new inter-operative connections is shown.
The basic “GaMField idea” is using magnetic and
gravimetric field linearity to model complex sources using a set of uniformly magnetized rectangular prisms.
The total intensity field at a given location is given by
the sum of each prism field. The user can specifically set
up a calculation volume divided into equal rectangular
prisms (the source grid). Once such volume has been set
up, the user needs to select the prisms to build up a magnetic or a gravimetric source.
In order to select such prisms GaMField package
provides ModelBuilder module, shown in Figure 2 [Pignatelli et al. 2011] (see block “ModelBuilder” in Figure 1).
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Figure 1. New GaMField modules and their inter-operative connections.

prisms and the different colours are there just to identify each prism boundary.
As shown in Figure 2, ModelBuilder allows selecting a horizontal layer by means of the combo box outlined by the green circle.

The source grid area is represented by a number
of parallel horizontal planes filled with red and blue
tiles in Figure 2. Each tile is the top face of a rectangular prism. Each prism extends up to the horizontal
plane beneath. At this stage, there are no magnetized

Figure 2. GaMField “ModelBuilder module”.
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Figure 3. User can “magnetize prisms” of a specific horizontal layer by clicking.

After selecting the horizontal layer, ModelBuilder
lets the user select prisms by clicking them and allows
to assign separately to each prism a different magnetic
angle and magnetization/density values as outlined by
the red circle in Figure 2. The assignment is done by
clicking on the desidered prisms as shown in Figure 3.
Alternatively , selecting “Polygon” option in the “Selection Mode” combo box, the user can also draw a
polygon and the software will automatically select all
the prisms inside it.

The “multiple Easting copy” and “multiple Northing copy” buttons (Figure 5, frame b)) can be used exactly as described in Pignatelli et al. [2011] and in
GaMField help for “Multiple layer copy” button.
2.2 Second upgrading feature: topographic source generation
The old version of GaMField was already provided
with some topographic simulation tools. A detailed description of such tools can be found in Pignatelli et al.
[2011] and in GaMField help. Basically GaMField allows
loading a DEM file and automatically build up a set of
prisms approximating the loaded DEM in order to
compute the corresponding magnetic or gravimetric
field (see block “DEM import” in Figure 1). In the new
GaMField version, we have introduced a new tool
called “DemGenerator”, providing the user with the
possibility to interactively build a synthetic topographic
model “drawing” isolines (see block “DEM freehand
builder” in Figure 1). The model produced by this tool
is meant to be uniform so inclination, declination and
magnetization/density will be the same for the whole
built structure. The user could possibly introduce vari-

2.1 First upgrading feature: selecting prisms using vertical section
As a lot of geosoftware registered users have
pointed out, ModelBuilder module is very efficient when
building horizontally extended sources. Unfortunately,
it is not so efficient for vertically extended sources. In the
new GaMField version, we have added the possibility to
choose “Easting layers” or “Northing layers” as shown
in Figure 4 (see also block “Depth Northing Easting
slices” in Figure 1). As one can see in Figure 5, the new
ModelBuilder GUI shows a couple of additional combo
boxes (indicated by the A frame) allowing such choice.
3

PIGNATELLI ET AL.

Figure 5. The new ModelBuilder interface. A) The new combo
boxes “Easting” and “Northing” B) “Multiple Easting” and “Multiple
Northing” layer copy C) Susceptibility to Magnetization conversion
button.

magnetization/density values;
- draw top and bottom surfaces by contouring;
- let DemGenerator build the DEM.
DemGenerator can be started by GaMField main
GUI by using the menu Topography -> Generate topographic model. The GUI in Figure 7 will be called.
The text boxes defined in “Area details” are
needed to define the area where the topography will
be generated as well as the prisms size, whereas the
section “Dem details” allows the user to set the magnetization/density values of the approximating
prisms. After filling in the above text boxes, the user
should confirm input parameters validity by clicking
“Confirm Parameters” button and then the top and
bottom surfaces can be defined. Basically it is needed
to write an altitude or depth into “Insert a top Isoline”

Figure 4. selecting prisms to be magnetized by means of horizontal or vertical sections.

ations using ModelBuilder module. The basic idea of
DemGenerator is to define a “top surface” and a “bottom surface” as shown in Figure 6. The two surfaces
will define the top and the bottom of the single layer of
prisms defining the DEM. Once the two surfaces have
been defined, this GaMField module will create uniformly dense/magnetized rectangular prisms with user
defined parameters. So basically, the following steps are
necessary to define a synthetic DEM:
- define an area where the two surfaces will be
built;
- define the prism horizontal sizes;
- define the whole DEM inclination, declination,

Figure 6. Top and bottom surface.
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Figure 7. The new tool DemGenerator.
Figure 10. Topographic model generated by DEMGenerator

will pop-up a figure showing the area coordinates and
the user can select the altitude/depth isoline by clicking as shown in Figure 8.
One can select as many points as needed and press
enter. The software will close the isoline connecting
the last clicked point to the first one as shown in Figure
9. When adding the next isolines, the software will
show the previous ones as shown in Figure 9.
Once the user has drawn all of the isolines, “Create Model” button needs to be clicked and the software
will generate a prisms ensemble approximating the selected pattern (see example shown in Figure 10). Basically, the software will generate a single layer set of
prisms where the horizontal coordinates are quantized
according to “Area details” parameters and the prisms
top and bottom are calculated by a linear interpolation
of the isolines defined surface.
The created model will be in GaMField and ModelBuilder format so the user can send it to GaMField by
using “Send to GaMField” button or open it into ModelBuilder by means of “Modify with ModelBuilder”
button. In the first case, the model will be loaded from
GaMField main module as a topographic model, so the
computation has to be done by using the menu Topography -> Compute Topographic Magnetic Effects.
In the latter case, the user will be prompted to insert
the thickness resolution for the model and then the
software will open ModelBuilder and the user will be
able to modify the source as described in Pignatelli et
al. [2011] or in GaMField help. In this case, after sending the final model to GaMField main module, the
field computation will be performed by using the
menu Compute -> Magnetic Field. Once a topographic model field has been computed, it can be exported into an ascii file by means of the menu File ->
Save topographic effects.

Figure 8. Selecting isolines in DemGenerator module.

Figure 9. Selecting isolines in DemGenerator module.

or “Insert a bottom Isoline” text box and click to the
button on the left of the selected text box. It is important to notice that vertical axis orientation is the same
as always used in GaMField, so the positive orientation
is downward. After clicking button, DemGenerator
5
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ble Tenerife Island Volcanic area or build a generic topographic model in the same zone. He/she just needs
to use “Real coordinates” button of DEM Generator
module (see Figure 7) and the software will prompt
with the dialog box shown in Figure 11 asking for a
real rectangular area boundaries specified in geographic coordinates (the ones in Figure 11 refer to
Tenerife island).
After inserting such coordinates, the software will
automatically take care of changing “Area details” text
boxes converting lat/lon coordinates into UTM projection of the selected area to guarantee the selected
geographic area as DEM building domain. A message
box will be prompted to specify the UTM projection
zone. The user will be able to “draw” the isolines on
the background shown in the Figure 12:
As stated before, the “real DEM” background will
not affect any computation and the DEM creation is
exactly how described in the previous paragraph, however, if the user wants to use the downloaded real
DEM as the topographic model to compute magnetic
or gravimetric field, he/she just needs to push “Extract
model” button. All the magnetic/gravimetric parameters chosen in DemGenerator gui will be used to
produce the topographic model. The only missing parameter is the bottom, so the user will be asked to input it. The program will exclude from the model every part of the DEM where the top is lower than the
bottom chosen by the user.
It is important to state here that this feature uses
Mathworks web server mapping service. Basically,
matlab runtimes will automatically look for web
servers providing DEM data available at request moment. So this feature working depends on third parties
servers providing data, so we cannot guarantee a constant and steady correct working. However, if issues
occur, we will try to find possible solutions and, if we
found them, provide upgrades to the users.

Figure 11. Dialog box appearing when using DEMGenerator “Real
Coordinates” button. The right input parameters for Tenerife Island
are shown.

Figure 12. Isolines of Tenerife Island to help user.

2.3. Third upgrading feature: STL files import and export
As reported by many users, even if ModelBuilder
module is a very good and efficient tool to simulate
magnetic sources, sometimes users are already skilled
on different 3d modelling software. That’s why, in the
new version of GaMField, we have introduced the possibility to import standard 3D model format files.
STL is a worldwide standard format for 3D triangular mesh surfaces, largely used in CAD-CAM and 3D
printing manufacturing flows. Many editors, ranging
from simple freeware to high end production suites, do
exist to build and manipulate such meshes.
To load an STL file, the user has to use the menu

2.2.1 Dem Generator: real coordinates tool
In order to make Dem generation easier and useful for realistic simulation, in the new GaMField version we have introduced the following possibilities:
(i) Build the topographic model using real coordinates;
(ii)Visualize real geographical topographies; (iii) Extract a topographic model from real DEM data.
The user has not to search or download any data,
he/she just needs an internet connection to use this
tool. Let’s assume, for example, the user wants to generate a synthetic DEM reproducing as much as possi6
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Basically, given the magnetic body susceptibility, GaMField perform the conversion to magnetization parameters by means of the following equations:
MT = MI + MR

(1)

where MT is the total magnetization. MI is the source
magnetization induced by the external magnetic field
and MR is the source remanent magnetization. The remanent magnetization, if wanted, should be introduced by the user by means of the three parameters:
|MR|: remanent magnetization intensity
IR: remanent magnetization inclination
DR: remanent magnetization declination

By means of the previous parameters, it is possible to compute the three cartesian magnetization components:
MRx = |MR| cos(IR) cos(DR)
MRy = |MR| cos(IR) sin(DR)
MRz = |MR| sin(IR)

(2)

MIx = Bχ/μ cos (II) cos (DI)
MIy = Bχ/μ cos (II) sin (DI)
MIz = Bχ/μ sin (II)

(3)

MI is the main field induced magnetization. Its cartesian components are given by:

Figure 13. STL import requester window.

Where: B is the main magnetic field module, II is
the main magnetic field inclination, DI is the main magnetic field declination, χ is the source magnetic susceptibility, µ is a constant given by: µ = 4π · 10−7 if the
susceptibility is given in S.I.units, µ = 10−7 if the susceptibility is given in c.g.s. units. Both unit systems can
be used in GaMField.
In GaMField, the user can perform such computation by using the ComputeMagneticParameters module. It can be opened when working with ModelBuilder
module by means of button Susc -> Magn Conv button
in ModelBuilder module or by “Special” menu in GaMField main GUI. The ComputeMagneticParameters
GUI is represented in Figure 14. The user can input all
remanent magnetization, susceptibility and main field
parameters and then get the magnetization module
and angular values.

File -> Model -> Load STL Model.
Some additional geometric parameters are entered
in the dialog window represented in Figure 13.
Once the parameters have been inserted, the STL
surface is converted to a set of prisms as any other
GaMField model. The user can see the resulting model
by means of View -> Built Model menu and perform
any other computation. Additionally, it is possible to export a ModelBuilder produced model as STL file using
command File -> Model -> Export model STL.
3. Additional minor changes to GaMField
3.1 Magnetization/susceptibility conversion
Another common requirement asked from
geosoftware forum members is about magnetic properties. The old version of GaMField uses both magnetization intensity and direction. Unfortunately, many researchers use magnetic susceptibility. So we have inserted
the possibility to immediately convert the susceptibility
to magnetization. In the new version of GaMField we
have introduced a suite tool to simplify the conversion.

3.2 Set survey parameters from model
One issue identified by Geosoftware users is related
to possible source/model missed alignment. Basically,
when confirming the input parameters, GaMField
checks survey parameters and model parameters inde7

PIGNATELLI ET AL.

for GaMField (produced externally or by using
ModelBuilder), we just need to use the menu
File -> Model -> Unify two models or the menu File > Model -> Unify more models. The software will automatically produce a single model including both of them.
3.4 Change whole source magnetic parameters
It has come out from users that sometimes the
source produced needs to be changed in terms of inclination, declination or magnetization. Basically the
user wants to change one or more of such parameters
without modifying structure geometry. In the new version of GaMField, one can find such feature in ModelBuilder, under the buttons “Change Inclination”,
“Change Declination” and “Change Magnetization”.
The software will ask for parameters to be used and a
confirmation from the user.

Figure 14. ComputeMagneticParameters module. The user can
input all susceptibility, remanent magnetization and main field parameters and then compute the magnetization parameters by using
“Compute” button.

3.5 Analytical signal
In the new GaMField version, the Analytical signal
computation has been added. The user has not to follow
any specific instruction but it will be computed only if
the “Compute Gradients” check box is selected. Then
the analytical signal could be saved or visualized by
means of the two menu View -> Complete Model effects and View -> Complete DEM effects as all other
computed components.

Figure 15. Add history dialog.

3.6 Fields comparing tool
A nice tool suggested by many users is the possibility to save different fields computed during the working session and compare them. For example, we would
like to compare the field generated by the same model
but at different elevations. In this GaMField version we
have added the possibility to insert one or more fields
into “history” which will be stored during the session.
The way to do it is by using menu Special -> Add Field
to History, Once this menu has been selected, GaMField
asks for a note to label such field. It is very important for
the user to choose a note expressing the field details. For
example a good note could be “Magnetic Field Altitude
300 m” as shown in the Figure 15.
If the user wants to compare some stored fields
he/she needs to use menu Special -> Compare Fields
tool and select the fields he/she wants to compare by
means of the combo box shown in Figure 16

Figure 16. Fields compare module.

pendently and does not perform any check to see if the
model is located near the survey area. This can be very
annoying because the field can be computed very far
from the source area and it can happen especially when
a model has been loaded. In the new GaMField version,
we have implemented a menu to help the user. Basically, under the menu File -> Survey parameters we have
added the menu “Set from Model”. The software will automatically modify survey parameters to make the survey area roughly cover the loaded source. The user can
further modify the survey parameters if he/she likes.
3.3 Unify two or more models
This feature could be very advantageous when the
user needs to build two models geographically very far
or having very different shapes so that it is inconvenient
to use the same ModelBuilder session to realize them.
In this case, let’s assume we have two or more models

4. Conclusions
GaMField was freely released for the first time
about six years ago and a lot of users have been registered at website http://geosoftware.sci.ingv.it to download it. During these years, we have received a lot of
8
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positive feedback and improvement proposals. This circumstance triggered the effort to release a new version
of the software where additional useful tools have been
integrated and made available to the scientific community through the same forum.
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